xentraveller

XenApp and other things Xen

Monthly Archives: June 2011

Wyse s10 published application not displaying right? v7.0.113 needs updating

Something that’s been noted is older vb6 published apps (there may be others) aren’t displaying in the taskbar on some s10 terminals running v7.0.113 of the firmware.

This means users can’t view apps when they are minimised as there is no way to select the said app again. Note: this is running the “Classic desktop”.

Wyse have released a newer version of their 7 firmware for the s10 line that fixes this issue. Keep in mind that you cannot rollback to a 6 firmware once any version 7 has been deployed. The version that fixed it for us was 7.0.217.

 

 

Advertisements

Xencenter 5.6 “Preparing to Import VM” issues?

I’ve been playing around with Xenserver 5.6 (unpatched) in a lab and found that when I run Xencenter 5.6 on a windows 7 64bit box it will not import VMs, in my case, the licensing pre-canned VM from Citrix.

It will just hang there after the storage section of the Import wizard “Preparing to Import VM”. As a work around I installed the console on a windows 2003 server and BAM it seemed to work great.

Office 20XX applications crashing in Xenapp6? clipboard may be to blame…

A problem I’ve seen was office applications crashing in xenapp 6 which runs on windows 2008 R2…

Nothing seemed to work, and the office apps were crashing with a seemingly random list of causes, even excluding DEP on the office binaries didn’t work.

After a bit of debugs with Microsoft they gave me a private fix for what looked to be a clipboard issue. The private hotfix worked, and will be released on the 15th/16th of June.

For those of you having issues with office apps (and maybe others crashing) on Xenapp6 or R2 this may help.

Article name is 2541119 and KB article (at the time of writing is not yet up on the MS site) will be here:

http://support.microsoft.com/default.aspx?scid=kb;en-US;2541119

Update this is now out:

Some applications may crash on a computer that is running Windows 7 or Windows Server 2008 R2. This issue usually occurs when you use the following applications:

  • Windows Explorer
  • Microsoft Office applications
  • Windows Movie Maker

CAUSE

This issue occurs because of a known issue in Ole32.dll. When certain applications implement the IEnumFORMATETC interface but do not implement the IEnumFORMATETC::Next() function correctly, Ole32.dll adds a malformed data structure to the system clipboard. When another process queries the Clipboard later, the processes may receive this malformed data structure. Therefore, heap corruption occurs in this process.

Office 2007 – roaming profiles and customising the quick access toolbar

It seems that the quick access toolbar was not designed to roam around with users, which can be annoying if they like to get their customisations on…

For those that are unsure what I’m on about, here’s a non customised word 2007

and a customised word 2007

Some customisations

The customisations (.qat files) are not stored in the roaming part of the profile, but instead, in the local part which means it won’t work when roaming.

I found a good blog over here that describes the problem, and the solution which involves a custom group policy that enables the feature in roaming profiles.